Driver AMD/ATI 8.42.3: ¡Por fin AIGLX!

24 10 2007

AMD ha publicado una nueva versión del driver privativo para sus gráficas (ATI). Sin duda una de ls versiones más esperadas debido a que entre sus novedades se incluye el esperado soporte para AIGLX.

Los usuarios de ATI hasta ahora tenían que hacer uso de XGL, que consiste en una capa intermedia entre sistema operativo y gráfica para proporcionar ciertas características que usa, por ejemplo, Compiz Fusion.

Es un sistema bastante antiguo y obsoleto ya que el rendimiento obtenido con AIGLX es mayor debido a que prescinde de ese intermediario. Pese a que se recibe con alegría, hay que dar unos tirones de oreja ya que han tardado mucho en ofrecer a los usuarios de GNU/Linux este soporte, comparado con NVIDIA que lo hizo 13 meses atrás.

Además del soporte AIGLX, se incluye soporte para X.Org server 1.4, mejoras en la reproducción de vídeo, otras mejoras de rendimiento y las acostumbradas correcciones de bugs.

Hay un pero, el driver al parecer no es del todo compatible con el kernel 2.6.23, aunque la próxima versión (8.43) sí lo será. Si sois usuarios de Ubuntu, tranquilos, el kernel que se usa actualmente es el 2.6.22.

· Descargar AMD/ATI driver 8.42.3 (x86 y x64)
· Notas de versión (8.42.3)

Ya podéis prescindir del paquete xserver-xgl, los que lo hayáis instalado, desinstalarlo, y lo mismo con el paquete de drivers privativos del gestor de controladores restringidos de Ubuntu (xorg-driver-fglrx). Desinstaladlo si los tenéis instalados.

Fuente: Phoronix

Más noticias entre tuxes y pepinos

Acciones

Information

62 responses

24 10 2007
Leizar

Ya lo he instalado con sudo sh y el nombre del archivo, instalo con automático, y depués al intentar activar efectos me dice Desktop effects could not be enabled, antes en la versión beta si me dejaba desde el mismo live cd, pero cuando entró la rc no me dejaba diciéndome la anterior frase, ahora con los esperados drivers ati 8.42.3 tampoco me deja incluso diciendo que tienen soporte aixgl, alguien puede decirme como puedo activar dichos efectos, gracias de antemano.

24 10 2007
24 10 2007
PaYaZo

habra que instalarlo nomas
para probar, ojala no deje la escoba😀
saludos

24 10 2007
dfm

Una pregunta: estos drivers se pueden usar con la ATI Mobility Radeon X1400? , digo, porque en la pagina oficial de ATI solo sale el 8.40.4 y cuando salio el 8.41 decian que solo funcionaba para las placas mas nuevas y que no se recomendaba usar con las mobility. Desde ya muchisimas gracias

24 10 2007
CristianG

@afm: Yo por mi parte no sé, pero yo tengo una ATI Mobility Radeon X1100 (en la página oficial de ati ni aparece) con este nuevo driver y anda de 10, proba instalándolo, de seguro que funciona… yo probé instalándolo ya que ni figuraba en la página oficial…
Salu2

24 10 2007
Kalani

@ dfm Yo lo instalé en una ATI mobility Radeon X1400 (Dell Inspiron 6400) la instalación finalizó correctamente, la pantalla va perfecta el único detalle es que no puedo abrir el ATI Catalyst Control Center, alguien sabe q ocurre?

24 10 2007
sowenesti

para un novato como yo… como instalo este driver? supongo que la mayoria sabeis y es una tonteria… pero la verdad es que no estoy muy seguro. una ayudita por favor?

24 10 2007
leillo1975

Yo tengo una ATI Radeon 9800 XT, y me pasa lo que pone DFM, que te vas a la página y te enlaza a la 8.40.4, ni siquiera a la ultima versión antes de esta…. Será compatible esta nueva versión con mi tarjeta? Si alguien lo prueba con tarjetas de la serie 9 y furrula que avise (no es que no quiera probarlo, es que estoy en el chollo con nvidia y el equipo con ATI lo tengo en casa y me puede la curiosidad)

Un saludo

24 10 2007
piponazo

Ya me lo he instalado y la buena noticia es que funciona😀. Al principio me las he visto negras para hacer funcionar compiz en mi ubuntu, pero googleando un poco descubrí que en “/usr/bin/compiz” hay que editar la “WHITELIST” y añadir el driver fglrx.

La mala noticia es que cuando estás funcionando con compiz, el rendimiento no es todo lo bueno que esperaba, por ejemplo el scroll en las páginas con firefox hace que la CPU se ponga al 100%. Sin embargo, si no tenemos los efectos de compiz activados, si he aumentado un rendimiento de aproximadamente un 40% en el número de frames haciendo un “glxgears”.

Por cierto, recomiendo hacer la instalación con la interfaz gráfica desactivada para evitarnos problemas, para ello:
* Control + Alt + F1 (Pasamos a modo consola)
* $ sudo /etc/init.d/gdm stop (si sois usuarios de kubuntu en vez de gdm, kdm)
* para instalar el driver primero damos permisos de ejecución al archivo “chmod +x nombrearchivo”. Después instalamos “sudo ./nombrearchivo.run”
* Por último editar la whitelist de compiz y añadir estas líneas a nuestro “etc/X11/xorg.conf” :

Section “Extensions”
Option “Composite” “0”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
EndSection

¿Como os ha ido la experiencia a vosotros?

24 10 2007
julitros

Se sabe algo de unas notas de versión en la que diga las compatibilidades e incompatibilidades?

Lo digo porque el ultimo que salio decia que si tenia una Mobility Radeon 9600 pasara de instalarlo… y no me la quiero jugar (ya sali airoso de un Kernel Panic antesdeayer y paso de mas sobresaltos :P)

Un saludo

24 10 2007
RikuTheRonin

Solo decir que esta NO ES UNA VERSION DEFINITIVA NI OFICIAL, es una no estable que se ha filtrado antes de tiempo.

Si bien es cierto que funciona (o eso dicen, no la he probado aun), pero aun en la web de AMD no aparece por eso mismo, porque no es una version definitiva. Fijaros que el enlace de descarga, no enlaca a la pagina de AMD.

Saludos.

24 10 2007
CeeC

@ RikuTheRonin: No estoy del todo seguro si es versión definitiva, o esperarán a la 8.43 para publicarla, junto con la lista de cambios, pero sí estoy totalmente seguro de algo:

1.- Es una versión oficial de AMD, no lo ha hecho nadie ajeno a la compañía.
2.- El fichero sí enlaza a la web de AMD, está alojado allí.
3.- En principio parece que está funcionando muy bien el driver. Puede que haya gente que tenga algún problema que otro, pero no es lo general y según he visto análisis de rendimiento en juegos y demás, parece que van por el buen camino (por fin).

Saludos.

24 10 2007
julitros

Bueno, instalado está🙂

Parece que funciona. Preguntas:

1) En la aplicacion “Pantallas y gráficos” me dice que sigo usando el fglrx ¿como cambio a aiglx?

2) Cuando en Apariencia -> Efectos de Escritorio paso de “ninguno” a “normal”, me sigue diciendo que la extension Composite no está disponible ¿ayuda?

Gracias y un saludo🙂

24 10 2007
Jordi

Hola ! lo intentado instalar pero creo que no ha ido. Fusion me iba más lento que con el xgl. He probado de arrancar glxgears para comparar y me reseteaba las X… ¿alguna ayudita? Graciasssss….

mobility x1300

24 10 2007
CeeC

Tened en cuenta que si instalasteis el paquete xserver-xgl obviamente tenéis que desinstalarlo o seguiréis usándolo innecesariamente. Y los que usásteis el driver que ofrece el gestor de controladores restringidos, también sería conveniente desinstalarlo, creo que se llamaba xorg-driver-fglrx. Podéis desinstalarlo mediante synaptic, aptitude purge, apt-purge, etc.

@ julitros: Está bien. fglrx es el nombre del driver, aiglx es un método de renderizado por así decirlo.

Saludos.

24 10 2007
Jordi

Ahhh!! vale, vamos a probar.. En el xorg hay que modificar algo ??

24 10 2007
Jordi

Bien… bueno, instalado está. Lo que ha dejado de funcionarme los efectillos del Fusion. He probado con composite “0” y con “1” y nada… habrá que esperar a ver!! ¡Saludos!

24 10 2007
julitros

Ok, he deshabilitado el driver propietario, desinstalado, y reiniciado.

Ahora GLXGEARS me va a 1950~1990 FPS.

Y los efectos de escritorio funcionan a FULL😀 Por fin ^_^

24 10 2007
manuator

yo tengo una Radeon 9550.
El anterior dirver no me funcionó y me tuve que volver a instalar el 8.40
Obiviamente ni efectos de escritorio ni Compiz ni ná parecido… pero consigo ver mi escritorio… que con el otro no veia nada

No se como hacer ahora.
¿primero deshabilito lo de los controles restringidos y luego instalo la nueva version?
¿como hago para poder volver a lo actual en caso de emergencia?
Creo q ahora uso el kernel 2.40 porque al actualizar a Gutsy me dio problemas y solo me arranca con este kernel. ¿Funcionará con el kernel que tengo?

24 10 2007
PaYaZo

quien tenra algun lapto con una X200 ???
para ver si le anda saludos

24 10 2007
» Nuevo Driver AMD/ATI 8.42.3 con soporte AIGLX Universo Linux: Grupo de Usuarios Universitarios de GNU/Linux

[…] Entre tuxes y pepinos Enlace: ATI Drivers & Software (aún no aparece en la […]

24 10 2007
24 10 2007
dfm

@CristianG, @ Kalani: Muchisimas gracias por la info apenas llegue del trabajo lo pruebo!!
@Kalani : Yo tambien tengo una Inspiron 6400, despues te cuento como me fue con el Catalyst.

24 10 2007
alexito4

He ido al tuto de mundo geek y aparte que no pone que tenemos que añadir las lineas esas que dice piponazo (cosa que hasta que no he echo no me dejaba iniciar sesion, he tenido que hacerlo en modo a pureba de fallos). Una vez añadidas las lineas, y reiniciar me ha dicho que mi equipo trabaja en baja resolucion y ahora tengo la resolucion de 800×600 :S

ALguna solucion?
Y sino, como puede volver a mi estado anterior??

Gracias.

Estaria bien que hicieses un tuto por aqui😀

24 10 2007
CeeC

No uso ATI y nunca he tenido una. Todo lo que publico me gusta probarlo antes para no escribir sobre algo que desconozco, así que no puedo hacer tutoriales para ATI, sorry.

En cualquier caso los detalles que están dando algunos usuarios son muy buenos para que os echen un cable.

Saludos.

24 10 2007
Festor

Una pregunta…. ¿esos drivers son oficiales? Lo digo porque…:

-Hasta el momento no han aparecido en la web oficial de ATI
http://ati.amd.com/support/driver.html

-No hay notas de lanzamiento
http://ati.amd.com/online/rss/atilinuxdriver.rss?OTC-rssfeedlinux

-Me da la impresión de que una, o es un fake (el driver), o dos no es un driver y sabe dios lo que puede ser….😦

¿Cual es la fuente de la noticia?

24 10 2007
CeeC

Una vez más, los drivers son oficiales, puede que no sean los finales (no son del todo estable aunque por lo que he leído dan muy pocos problemas, simplemente faltan algunas incompatibilidades como con el kernel 2.6.23 como dije en la noticia) y por esto no salen aún en la web, no son fake ni nada por el estilo.

Repito, el fichero está alojado en la web de AMD y se esperaba que este mes se publicara el driver de ATI con soporte con AIGLX, no busquéis las cinco patas al gato, el driver es real xD

La fuente despiste mío, fue phoronix, ya está añadida.

Saludos.

24 10 2007
dfm

Todo instalado a la perfeccion, solo que compiz funciona MUCHO PEOR!! que con el driver 8.40 y xgl, ha alguien le sucede lo mismo?

@Kalani : a vos te funciona bien? ya que tenemos la misma maquina y la misma vga (inspiron 6400 y mobility radeon x1400). El catalyst no lo instale todavia, queria probar como andaba el driver.

24 10 2007
CeeC

Para los desconfiadillos y los que quieran algo más de info, aquí tenéis las notas de versión del driver. Lo he añadido también a la noticia.

Saludos.

24 10 2007
Festor

Nu se… pero ya me direis porque no aparece en la web oficial ni en el feed de las notas de lanzamiento:

http://ati.amd.com/online/rss/atilinuxdriver.rss?OTC-rssfeedlinux

Además de que leyendo por la red hay muchos usuarios que reportaron numerosos problemas con este driver llegando incluso a que Ubuntu no lo usa y usa los Mesa directamente….

Digo esto porque me interesa actualizar las guias de instalación de los controladores de ATI para Ubuntu pero con todo eso de que parece que no es la version final o no es el oficial…. nu se😦

24 10 2007
festor

Más info, CeeC, según esas notas de la versión del driver:

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.42.3.html

Dice explicitamente:

“AMD recommends that this release of the AMD Proprietary Linux software driver not be used for distribution packages. Distributors should continue to use the AMD Proprietary Linux driver version 8.40.4”

Que ma o menos viene a decir que es mejor seguir usando la versión 8.40.4, no? Es decir la distribución del driver por medio de la creación de paquetes .deb (el método más usual y recomendado) no es muy recomendable para la 8.42.3…

24 10 2007
CeeC

Y repetimos, como las natillas xD, sí es oficial, aunque puede que no sea final. Esto último explica por qué no está aún en la web de descargas de AMD y que recomienden que no se use aún, es una forma de “salvarse el culo” xD

Para cualquier versión de drivers de AMD/ATI vas a tener a muchos usuarios con problemas, porque no saben instalarlos, o hay alguna incompatibilidad y no lo saben (léase el tema de no desinstalar los drivers de Ubuntu o el servidor XGL), etc.

Ten en cuenta que este cambio de versión no es como las anteriores ya que incorpora AIGLX y puede provocar conflictos a aquellos usuarios que estén usando el servidor XGL, por eso se pueden alzar más voces, pero se deben más a la ignorancia que al driver.

Por lo que yo he leído por ahí, aunque puede que no esté al 100% el driver está haciéndolo bastante bien. Por otro lado quien quiera estar seguro del todo, pues que se espere a la 8.43 que supongo que sí la pondrán en la web y listos.

Saludos.

24 10 2007
Kaiser Z

Pues lo isntale como dicen y me cargue el compiz😦 ya nada sirve me dice que no puede ejecutar lo de las vetaas, ose el compiz, haber si despues sale un tuto mas exacto.

Kaiser Z

25 10 2007
alber

Para Leizar y para todos los usuarios ATI que se encuentren con “Desktop effects could not be enable”

Escribis en terminal:
sudo gedit /usr/bin//compiz

Ahora os dirigis a la linea 54 (aproximadamente) Buscais donde pone:”whitelisted” y el nombre del driver entre comillas, pues sustituis ese nombre por “fglrx”

Listo, os vais a Sistema>apariencia y todas las opciones están disopibles con todos los efectos. =D

25 10 2007
josesptala

A mi me sigue poniendo lo de Desktop effects could not be enabled

Tengo una mobility radeon X1100

25 10 2007
Jesus

Yo converti el .run a paquetes deb, primero desisntale el xserver-xgl, y en fin, hize todo lo que venia en la web de phoronix. El driver se instala correctamente, pero de ahi a funcionar hay un buen tramo. Arranca bien, pero sale el pantallazo blanco si activo compiz en el apartado de apariencia. La segunda vez que lo intente, reinicie el equipo antes de probar nada, y esta vez se inicia en 640×480 y solo deja usar como maximo 800×600, y tambien sin efectos de compiz. Total, un desastre, de momento he vuelto al driver ati que viene con gutsy y al xgl, que aunque no es una maravilla por lo menos funciona.

25 10 2007
neoubay

Os comento los pasos que he seguido yo, que me han funcionado después de algún quebradero de cabeza. Tengo una ATI X1600

Tras bajar el driver he desinstalado el xserver-xgl.
En Sistema->Administración->Pantallas y gráficos me he asegurado de marcar como driver el fglrx.
No he desisnstalado el paquete xorg-driver-fglrx.

Tras esto, intenté crear el paquete específico del driver para Ubuntu gutsy, pero no pude, así que lo instalé en el modo automático.

Una vez instalado reinicio el sistema (no el modo gráfico sino que reinicio el ordenador).

Compruebo que el driver está correctamente instalado con: glxinfo | grep direct

Hago una copia de seguridad del xorg.conf por si las moscas y luego lo edito activando el Composite:
Section “Extensions”
Option “Composite” “1”
EndSection

Activo el AIGLX añadiendo:
Section “ServerFlags”
Option “AIGLX” “on”
EndSection

Tras esto edité la WHITELIST del compiz:

sudo gedit /usr/bin/compiz

Bucando las líneas:
# Driver whitelist
WHITELIST=”nvidia intel ati radeon i810″

Y sustituyendo por:
# Driver whitelist
WHITELIST=”nvidia intel ati radeon i810 fglrx”

Tras esto reinicié el modo gráfico y premio! Ya me funcionaba compiz.
Espero haber ayudado a alguien. Felicidades por el blog es una de mis Biblias de Ubuntu.

25 10 2007
Kalani

@dfm, bro te comento como fué que hice mi instalación (en Dell Inspiron 6400) y ya funciona todo pro!

1.-Desinstalé el XGL: sudo aptitude purge xserver-xgl

2.-Desinstalé el fglrx: sudo aptitude purge xorg-driver-fglrx

3.-Descargué el driver y debido a que en la versión x64 existe un bug que impide empaquetarlo le di permisos de ejecución y lo heché a andar como superusuario.

4.-Después checas si tienes activado el controlador Restringido:
Sistema -> Administración -> Gestor de controladores restringidos, sino lo tienes acticado, habilitalo.

5.-Edita el xorg.conf sudo gedit /etc/X11/xorg.conf

6.-Con la herramienta buscar identifica alguna de estas partes:
Option “Composite” “0”
Option “Composite” “Disable”
Option “AIGLX” “off”

(La que me apareció a mi fue la primera) y comentalas colocando # al principio de cada linea.

7.-Agrega el driver a la lista blanca de soporte de CF editando
sudo gedit /etc/xdg/compiz/compiz-manager
y agregas al final:
WHITELIST="fglrx"

De esta forma tengo mi Compiz-fusion pro, el catalyst andando y sin ninguna bronca ;)

25 10 2007
Icaro

Yo hago lo mismo mas o menos que neoubay, el unico cambio es que yo si desinstale el fglrx antiguo antes de instalar el nuevo, y nada no consigo activar la aceleracion 3D con mi x1700:

glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

25 10 2007
Kaiser Z

Regreso contando que he logrado hacer funcionar el driver y va de maravilla, eso del XGL gears o algo asi no sabia que era, pero lo investigue y lo encontre y lo puse en mi terminal y me dio esto :O

kaiser@KaiserZ:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
5104 frames in 5.0 seconds = 1020.800 FPS
5024 frames in 5.0 seconds = 1004.800 FPS
5005 frames in 5.0 seconds = 1001.000 FPS
5011 frames in 5.0 seconds = 1002.200 FPS
5013 frames in 5.0 seconds = 1002.600 FPS

No se que signifique ¿alguien me lo podría explicar?, por lo demas el compiz no servía pero leyendo la ayuda en este foro me tope con el post de alber y modifique lo que ponía el, ya que me daba el error que el comentaba, y voila, compiz funcionando, he de decir que solo modifique ese parametro y nadamas.

El catalyst funcionando tambien de 10 y con varias opciones muy buenas, y he de decir que tras la instalacion me aparecieron cuatro paquetes debs….. y no se que hacer con ellos ya que tienen un candado y no los puedo eliminar.

Kaiser Z

25 10 2007
Joe La Bug

Tras intentar instalar el driver propietario, he tenido que dar marcha atrás, debido a algunos problemas ya mencionados. No obstante, como algunos pasos no los había hecho, volveré a probar.

El caso es que desinstalados los fglrx, las ventanas se mueven muuuuuuuuuyyyyy lentamente. Probablemente por algún conflicto de drivers. ¿Qué debería hacer?

Gracias por anticipado

25 10 2007
CeeC

Gracias por compartir vuestros pequeños howtos. Ayudarán a mucha gente😉

Saludos.

25 10 2007
dfm

@Kalani: Desde ya muchisimas gracias por la info, por lo que contás tenes un micro de 64bits? Yo tengo un core 2 duo de 32 bits y por ende realicé la instalacion a traves de la generacion de paquetes .deb, la verdad es que salió todo bien, se instalaron los drivers correctamente logrando la aceleracion 3d, solo que los efectos me andan mucho mas lentos que cuando usaba xgl.

La diferencia con tu instalacion (ademas de instalar por paquetes y no en automatico) es que yo tuve que deshabilitar el driver en los controladores restringidos ( sudo nano /etc/default/linux-restricted-modules-common y agregar la linea DISABLED_MODULES=“fglrx“ ) porque sino tenia conflictos con la carga del modulo del kernel, (en el syslog me decia que no concordaban las versiones del driver con la del modulo del kernel), ademas tuve que agregar una entrada al archivo /etc/modules para que me cargue el modulo correcto (sudo echo “fglrx” >> /etc/modules).
De esta forma se instalo todo bien, solo que funciona muy lento. Si alguien puede decirme por favor si hice algo incorrecto en mi procedimiento se lo agradecería mucho.
Igual voy a probar con un instalacion automatica (a mi pesar, porque no me gustan los automatismos donde nose que se hizo) y habilitando el driver en controladores restringidos a ver que onda. Si sale bien les cuento!!

25 10 2007
sergio

a mi me funciona todo perfecto..🙂 gutsy + compiz fusion + ATI Radeon 600

los videos y todo en general va perfecto, los efectos del compiz tambien, los e ido probando todos y perfecto

he hecho una instalacion completa, descargando la imagen de Ubuntu 7.10 en DVD, que pesa unas 4GB, actualizando e instalando el driver de ATI 8.42.3… y todo perfecto..
(me habia dado algun error al descargar paquetes con la instalacion en CD)

26 10 2007
Top Posts « WordPress.com

[…] Driver AMD/ATI 8.42.3: ¡Por fin AIGLX! AMD ha publicado una nueva versión del driver privativo para sus gráficas (ATI). Sin duda una de ls versiones más […] […]

26 10 2007
ferrandinyo

A mi el nuevo driver me funciona bien, he notado que ha subido el rendimiento de mi ati X700. Pero no consigo habilitar los efectos de compiz-fusion.
Se sigue poniendo “Desktop effects could not be enabled” incluso después de haber añadido “fglrx” al WHITELIST, tanto en /etc/xdg/compiz/compiz-manager
como en /usr/bin/compiz.
Alguien sabe como solucinar esto?
Gracias

26 10 2007
ferrandinyo

Solucinado!!
Antes se me habia olvidado mencionar que mi grafica era la del laptop, una ati x700 mobile.
La solución la he encontrado en 120% Linux, resula que para la ati x700, aparte de añadir “fglrx” al WHITELIST en /usr/bin/compiz, tambien hay que quitar (en el mismo archivo), el PCIID ‘1002:5653′ de la lista negra, que es el que corresponde a la x700.
Ahora si, aceleración gráfica i compiz con aiglx.

26 10 2007
Joe La Bug

Pues a mi no ha habido manera de que funciones y he vuelto atrás. Antes de hacer otras pruebas, prefiero esperar a la 8.43 y mejor aún, a que liberen los drivers.

26 10 2007
Leizar

Yo he probado lo que dice ferrandinyo y funciona, lo de quitar de la lista la ati x700 que es la que tengo yo la mobility radeon x700 pero al activar los efectos de compiz me va muy lento, es como si le costase tirar bien, alguien sabe como puedo aumentar el rendimiento??gracias

26 10 2007
Joe La Bug

@Leizar
Comprueba que tengas habilitado la opción en Sistema –> Administración –> Gestor de Controladores Restringidos

27 10 2007
27 10 2007
ivan

con ati x1250 instalo l driver y al reiniciar , en el login la pantalla a oscuras, no se ve nada. Os a pasado a alguien esto?… y lo mejor… sabeis como puedo hacer para que vuelva la imagen?… no encuentro nada por los foros. gracias

27 10 2007
leizar

@Joe La Bug tengo habilitado dicho controlador, al poner compiz en marcha en el menú sistema preferencias apariencia, en modo normal va lento, al hacer un simple gesto como es coger varios iconos con arrastrar y seleccionar, va como si no tuviese aceleración gráfica, cuando puedo jugar a juegos como nexuiz y demás sin ralentizarse nada, si alquien le pasa lo mismo que diga como lo ha solucionado, de todas formas Joe La Bug muchas gracias por contestar.

27 10 2007
leizar

@ivan, prueba a configurar el xorg.conf a mano, puedes hacerlo desde modo recuperación, en la pantalla del grub, (modo de recuperación) cuando cargue haces,
cd .. cd .. cd etc cd X11 sudo editor xorg.conf, en la sección que pone esto:
Section “Device”
Identifier “ATI Technologies Inc Radeon Mobility X700 (PCIE)”
Driver “fglrx” –> aquí añadir ati
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “on”
Busid “PCI:1:0:0”
EndSection
añadiendo ati te debería volver a iniciar la pantalla de bienvenida, luego puedes probar a compilar el driver para la versión de linux que uses.

28 10 2007
Nando

ps yo ayer en la noche instale los drivers nuevos y todo se veia vien pero a la hora de kere cargar compiz me decia que no se pudo le hice y le deshise y nada segui varios tutoriales ; ; … asi que decidi instalarlos en una instalacion limpia de ubuntu y ahora trabajan de lujo compiz-fusion al 100%.. esto es con una x1950pro 512 agp

31 10 2007
archlinux

Yo intenté usar fglrx hace un tiempo y de terror, así que me pase a los libres (no de ATI/AMD) son un poco mas lentos en FPS pero jamás un problema.
Para quien quiera…
# pacman -S libgl-dri
# pacman -S xf86-video-ati

y a disfrutar de compiz con AIGLX..yo estoy con xorg 7.2
bye

5 11 2007
Daniel Venezuela

Alguien lo ha probado con una ATI x1300?

7 11 2007
kampanita

@Payazo: Yo lo tengo con una ATI Radeon Express X200 en el portatil funcionando correctamente.

Me funciona correctamente Beryl ( mejor que con los drivers fgrlx ), pero no consigo arrancar Compiz Fusion….me da un error :

/usr/bin/compiz.real (core) – Fatal: No GLXFBConfig for default depth, this isn’t going to work.
/usr/bin/compiz.real (core) – Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) – Fatal: No manageable screens found on display :0.0

He buscado informacion por google de este error, pero no consigo solucionarlo de ninguna manera.

10 11 2007
LoBo

He probado de todas las formas posibles que se han puesto en las respuestas, y no consigo echar a andar compiz fusion con estos controladores, la verdad es que soy bastante nuevo en linux y aun no se manejarme. He instalado el driver, he desintalado el xserver-xgl y el xorg-driver-fglrx, he modificado el xorg.cong y los compiz y compiz-manager y nada, no consigo tener aceleracion 3D, no se me abre el CCC y no y sigue pidiendome el composite para echar a andar el compiz fusion.
Salu2

10 11 2007
LoBo

Se me olvido comenta que es un Acer Aspire 5104 con una ati X1100.

Salu2

11 11 2007
LoBo

Al final he conseguido echar a andar todo, pero con una velocidad bastante mala, 1200 FPS de media y con el XGL me llegaba a los 2500. De momento creo que andare con los XGL hasta que salgan unos drivers de ATI mas estables.

Salu2

18 11 2007
sowenesti

buenas compañeros

voy a pediros ayuda y a ver si me conseguis ayudar. soy mas o menos nuevo en ubuntu y la verdad es que estoy muy contento pero tengo problemas con mi tarjeta ati radeon 9550.
cuando instale gutsy gibon no tuve ningun problema, el monitor se veia de cine y ponia la resolucion que yo queria sin problema, pero cuando vi esta entrada hace ya tiempo con ganas me puse a intentarlo. no lo consegui, no consegui hacer que funcionase correctamente, y aunque me queda algun howto de los que hay por aqui arriba por probar ya no se que hacer….
cuando puse los drivers de ati, solo podia poner una resolucion de 800 x 600 y claro asi no se podia quedar, en algunas ventanas no veo ni los botones de aceptar jeje
desde el gestor de drivers privativos desinstale el driver y volvi a tener los de ubuntu por defecto todo bien de nuevo.

fue entonces cuando ayer encontre otro tutorial de como poner los drivers y lo volvi a intentar con nefasto resultado, con los ati lo veo mal, pero cuando los desintalo y vuelvo a los genericos ( supongo que son los que usa al desinstalar los de ati) sigo con la resolucion de 800 x 600 cuando antes iba bien.

en administracion – pantalla y graficos e visto que puedo seleccionar mi tarjeta y tal, cada vez que elijo la mia me manda reiniciar el sistema y cuando reinicio ya no esta marcado lo que yo e puesto por lo que sigue todo mal, no se queda el driver y las opciones de monitor que yo le e indicado y esto me lleva a una voragine de reinicios y desesperacion jeje

alguien sabe como poder quitar toda la mierda que le alla podido meter y que vuelva a funcionar como cuando todo iba bien? alguien con alguna ayuda?

gracias y espero no haber aburrido mucho con este pedazo tochazo😀

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: